Skip to content

chore(deps): patch undici advisories via override (>=6.27.0) - #193

Merged
tamino-martinius merged 1 commit into
mainfrom
tm/undici-vuln-fix
Jul 16, 2026
Merged

tamino-martinius merged 1 commit into
mainfrom
tm/undici-vuln-fix

Conversation

@tamino-martinius

Copy link
Copy Markdown
Owner

What

Resolves the four open Dependabot alerts for undici (all fixed in 6.27.0):

Severity Advisory
High GHSA-vxpw-j846-p89q
Medium GHSA-p88m-4jfj-68fv
Low GHSA-35p6-xmwp-9g52
Low GHSA-g8m3-5g58-fq7m

Why / how

undici was pulled in transitively at 6.25.0 via node-gyp — an optional native-build dependency of sqlite3 — and is not declared in any workspace package.json. Added a root pnpm.overrides entry, matching the existing override style:

"undici@<6.27.0": ">=6.27.0 <7"

The <7 upper bound is deliberate: node-gyp@12.3.0 requires undici ^6.25.0, and an open-ended >=6.27.0 would let pnpm resolve to undici 8.x (the latest tag), breaking that range. 6.27.0 is the latest 6.x line and the patched version, satisfying both the advisories and node-gyp. The lockfile now resolves undici to 6.27.0 everywhere.

HISTORY

Documented under ## vNext in the three packages whose dependency tree includes node-gyp — aurora-data-api-connector, knex-connector, and migrations — matching the scope of the prior tar override note (same node-gyp chain).

Verification

  • pnpm install --frozen-lockfile passes; no undici < 6.27.0 remains in the lockfile.
  • Release-notes/HISTORY tooling tests (pnpm test:release) pass (27/27; the unrelated no-eval-in-dist check requires a prior pnpm build and is not affected by this change).

Resolves four open Dependabot alerts for undici (all fixed in 6.27.0):
high GHSA-vxpw-j846-p89q, medium GHSA-p88m-4jfj-68fv, and low
GHSA-35p6-xmwp-9g52 / GHSA-g8m3-5g58-fq7m.

undici was pulled in transitively at 6.25.0 via node-gyp (an optional
native-build dependency of sqlite3), not declared in any package. Added a
root pnpm.overrides entry `undici@<6.27.0` -> `>=6.27.0 <7`. The upper
bound keeps undici on the 6.x line so it stays within node-gyp's
`^6.25.0` range (an open-ended `>=6.27.0` would let pnpm resolve to
undici 8.x and break node-gyp).

Documented under vNext in the HISTORY of the three packages whose
dependency tree includes node-gyp: aurora-data-api-connector,
knex-connector, and migrations.
@github-actions

Copy link
Copy Markdown
Contributor

Coverage report

Package Statements Branches Functions Lines
arktype 80.76% 73.40% 87.50% 90.90%
aurora-data-api-connector 80.40% 60.42% 96.42% 82.97%
core 88.54% 80.64% 89.72% 90.26%
express-rest-api 89.47% 76.99% 100.00% 93.05%
graphql-api 86.32% 68.71% 97.05% 90.33%
knex-connector 80.89% 68.30% 91.34% 83.48%
local-storage-connector 95.87% 93.93% 90.47% 95.55%
mariadb-connector 87.40% 78.87% 85.00% 91.42%
migrations 98.63% 89.10% 100.00% 98.85%
migrations-generator 94.64% 87.75% 100.00% 100.00%
mongodb-connector 83.72% 69.31% 82.97% 87.00%
mysql-connector 77.11% 60.23% 83.54% 79.95%
nextjs-api 82.59% 73.01% 97.50% 85.92%
postgres-connector 84.05% 68.48% 91.25% 86.20%
react 93.73% 83.10% 89.74% 94.45%
redis-connector 80.15% 59.17% 89.09% 84.82%
sqlite-connector 85.22% 72.86% 91.96% 87.78%
supabase-connector 95.19% 87.82% 100.00% 97.35%
typebox 83.11% 70.31% 93.33% 93.10%
valkey-connector 100.00% 66.66% 100.00% 100.00%
zod 85.88% 72.30% 92.85% 94.11%

Posted by .github/scripts/coverage-comment.mjs.

@tamino-martinius
tamino-martinius merged commit fa2bd62 into main Jul 16, 2026
58 checks passed
@tamino-martinius
tamino-martinius deleted the tm/undici-vuln-fix branch July 16, 2026 19:17
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant