Repository navigation
Remediate Axios CVEs by upgrading to 1.18.1 and removing vulnerable transitive path - #547
Merged
Merged
Conversation
Copilot
AI
changed the title
[WIP] Fix Trivy reported CVEs for axios 0.21.4
Remediate Axios CVEs by upgrading to 1.18.1 and removing vulnerable transitive path
Jun 23, 2026
rogene-bcgov
marked this pull request as ready for review
June 23, 2026 23:02
Contributor
There was a problem hiding this comment.
Pull request overview
This PR remediates Trivy-reported HIGH CVEs by upgrading the client’s Axios dependency to 1.18.1 and removing dev dependencies that were retaining the vulnerable axios@0.21.4 in the lockfile graph.
Changes:
- Upgrade
axiosfrom^0.21.1to1.18.1and add an npm override to enforce resolution. - Remove
lite-serverandconcurrently(and simplify thestartscript to runreact-scripts startdirectly). - Regenerate
client/package-lock.jsonto eliminateaxios@0.21.4and related transitive entries.
Reviewed changes
Copilot reviewed 1 out of 2 changed files in this pull request and generated 1 comment.
| File | Description |
|---|---|
| client/package.json | Pins Axios to 1.18.1, adds overrides, and removes dev tooling/scripts that pulled in vulnerable transitive deps. |
| client/package-lock.json | Updates the resolved dependency graph to reflect Axios 1.18.1 and removal of lite-server/concurrently transitive chain. |
💡 Add Copilot custom instructions for smarter, more guided reviews. Learn how to get started.
Co-authored-by: Copilot Autofix powered by AI <175728472+Copilot@users.noreply.github.com>
Collaborator
|
All tests good. Merging this now. |
|
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.



Trivy flagged multiple HIGH CVEs on
axios@0.21.4in the client dependency graph. This PR removes all0.21.4references from the client lock graph by upgrading Axios and eliminating the transitive source that kept the vulnerable version pinned.Dependency remediation
axios@^0.21.1toaxios@1.18.1.axios@1.18.1resolution in the dependency tree.client/package-lock.jsonto reflect upgraded Axios artifacts.Transitive vulnerability source removal
lite-serverandconcurrentlydev dependencies, which introducedlocaltunneland retainedaxios@0.21.4in lock metadata.startscript to runreact-scripts startdirectly.serverscript tied tolite-server.Files updated
client/package.jsonclient/package-lock.json{ "dependencies": { "axios": "1.18.1" }, "overrides": { "axios": "1.18.1" }, "scripts": { "start": "react-scripts start" } }Thanks for the PR!
After merge, new images are deployed and promoted to DEV: