Repository navigation
Drop end-of-life Python 3.9 support - #213
Merged
Merged
Conversation
Co-authored-by: felickz <1760475+felickz@users.noreply.github.com>
Contributor
Dependency Review✅ No vulnerabilities or license issues or OpenSSF Scorecard issues found.Scanned FilesNone |
Contributor
There was a problem hiding this comment.
Pull request overview
Drops end-of-life Python 3.9 support across the repository by aligning CI matrices and documentation with the effective minimum supported version implied by vendored dependencies.
Changes:
- Updated GitHub Actions workflow matrices to start at Python 3.10 (and updated related required-check references).
- Updated user-facing documentation to state Python ≥ 3.10 / 3.10+.
- Updated CLI wrapper scripts’ “Python not installed” messaging to reference 3.10.
Show a summary per file
| File | Description |
|---|---|
| README.md | Updates stated minimum Python requirement to ≥ 3.10. |
| CONTRIBUTING.md | Updates contributor setup requirement to Python 3.10+. |
| policy-as-code | Updates missing-Python message to reference 3.10. |
| policy-as-code.ps1 | Updates missing-Python message to reference 3.10. |
| .github/workflows/main.yml | Removes 3.9 from the main CI matrix (now 3.10–3.13). |
| .github/workflows/cli.yml | Removes 3.9 from the CLI workflow matrix (now 3.10–3.11). |
| .github/workflows/docs.yml | Bumps docs build Python version to 3.10. |
| .github/workflows/vendor-sync.yml | Updates required-check name references to match the new main matrix. |
| .github/instructions/markdown.instructions.md | Updates required-check reference string to match the new main matrix. |
Review details
💡 Add a code-review agent skill or configure MCP servers for context-aware, tailored reviews. Learn more in the docs.
- Files reviewed: 9/9 changed files
- Comments generated: 2
- Review effort level: Lite
Comment on lines
11
to
13
| else | ||
| echo "Python is not installed. Please install Python (+3.9) and try again." | ||
| echo "Python is not installed. Please install Python (+3.10) and try again." | ||
| echo "Make sure that Python is added to the PATH environment variable." |
| python -m ghascompliance $args | ||
| } else { | ||
| Write-Host "Python is not installed. Please install Python (+3.9) and try again." | ||
| Write-Host "Python is not installed. Please install Python (+3.10) and try again." |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Vendored dependencies (
ghastoolkit0.18.3,requests2.34.2,urllib32.7.0) already require Python ≥ 3.10, sinceurllib3evaluates PEP 604 union syntax (X | Y) at import time. Any vendor-dependent job on 3.9 fails at import with aTypeErrorinvendor/urllib3/_base_connection.py, unrelated to first-party code. With 3.9 also EOL upstream, we drop it repo-wide rather than patch around it.main.yml:3.9-3.13→3.10-3.13cli.yml:3.9-3.11→3.10-3.11docs.yml:setup-pythonbumped to3.10README.md/CONTRIBUTING.mdminimum requirement updated to Python ≥ 3.10policy-as-code/policy-as-code.ps1"Python not installed" messages updated3.9references invendor-sync.ymlrequired-check names andmarkdown.instructions.mdupdated to match new matrix